GeekInterview.com
Series: Subject: Topic:
Question: 951 of 1131

Unable to start my Informatica Repository Service Windows XP and Oracle 10g

I am unable to start my Informatica Repository Service, Even if I start the service, it stops immediately.Please, any one have a solution to this problem(I installed Informatica 7.1 on WINDOWS XP Home Edition, Oracle 10g)Thanks a lot.nagesh
Asked by: Interview Candidate | Asked on: Jan 30th, 2006
Showing Answers 1 - 53 of 53 Answers
Niraj Kumar

Answered On : Feb 23rd, 2006

open workflow manager and configure/assign the Server. Then Start the IRS. 

  
Login to rate this answer.
Priya

Answered On : Mar 31st, 2006

 hi...My name s priya,i am facing the same problem i hav installed Informatica 7.1 on my pc yesterday,but I am unable to start my Informatica Repository Service, Even if I start the service, it stops immediately.Please, if you hav got the solution to this problem reply my immediatelyi am lagging behind in my class i want to finish up with my exercises as soon as i can ....please help...priya

  
Login to rate this answer.
Raj

Answered On : Apr 4th, 2006

Hi Priya..i think while installing you have not installed properly.. i recomend you to install the software  once again and check the setting in repository services..I hope this will give the solution..CheersRaj

  
Login to rate this answer.
suresh maddineni

Answered On : May 14th, 2006

I think first u open the workflowmanager,configure properties of repository then conn to repository server

  
Login to rate this answer.
chinna

Answered On : May 20th, 2006

hi friend...i am also facing the same problem..i have installed informatica 7.1 on windows-xp system.but i couldnt connect to the repository server..i think i couldnt have done the configuration properly.so, if u get the solution, plz mail me the detailed steps of configuring informatica server, repository server and all required steps.one request.. plz be clear while providing me the steps..plz provide them sequentially..onething.. i have installed informatica in my system with out the database(oracle).. if that is the problem, plz let me know that..thanks in advance..chinna

  
Login to rate this answer.
venky

Answered On : May 22nd, 2006

hiEven i have the same problem of starting Informatica Repository Service. Tried the above solution and have even reinstalled Informatica 7.1 twice.Pls help.. need to start practise.thanksvenky 

  
Login to rate this answer.
Harikrishna

Answered On : Jun 2nd, 2006

server setup problem.first check computer ip address or compuer names are defined properly.after that start up the reposory using admin console.then go to workflow and configure server and run the service.

  
Login to rate this answer.
Patza

Answered On : Jun 18th, 2006

Hi, I too is unable to start Informatica server service...if I start...it stops immediately...I'm running Informatica 6.1 on Windows 2000 server. I also tried re installing the Informatica server. Any Idea how to resolve this problem.Thanks- Patza

  
Login to rate this answer.
Rakesh

Answered On : Jun 25th, 2006

Hi,While installing Informatica server it propmted me to put Platform Key, Oracle Key etc. I think we need atleast three keys to install 1. Platform key2. Oracle Key3. ODBC keyI do not have these keys. Can somebody share ? you can reach me at unadkat_rakesh@yahoo.com PLEASE HELP !!!

  
Login to rate this answer.
Motilal

Answered On : Jun 30th, 2006

After installing the Tool,Go to start-->all programs-->repository server-->repository server setupcofigure there the port number and admin password..clik ok.Then go to service .. right clik on Informatica repository service.. clik properties.Then click on the log On tab.. and click the log to local computer radio button there. Click ok.then start the service...lemme kno if any probs further..and about license keys for some body... if u already got it.. ignore..else scrap the powercenter version.. will try to give u.

Yes  1 User has rated as useful.
  
Login to rate this answer.
Alekya

Answered On : Aug 18th, 2006

Hi Everyone,                    This problem is with the Windows XP Home.Thats the reason why everytime u start the services it gets disconnected. You need to have a Windows XP Professional. The XP Home version doesnt support one functionality compared to XP Professional. That function is IIS(Internet ... Services).I am not sure about the correct abbreviation but you will find it in XP Professional.Thanks,Alekya.

  
Login to rate this answer.
harshaaA

Answered On : Aug 30th, 2006

hi priya its better once you uninstall the software and restart the system and then  reinstall software then u will be get working well. even though if  u get the same problem plz change ur operating system  Generally win XP professional service pack2 is very gud for testing.bye

  
Login to rate this answer.
Kishore

Answered On : Oct 3rd, 2006

You need to change the Operating System that is the solution for your problem.  Windows XP Professional or Windows 2000 Advanced Server or WINDOWS NT will be ideal.

  
Login to rate this answer.
lingesh

Answered On : Nov 9th, 2006

Hi friends,                   I think this link will help you while installing informatcia.http://www.lesterboal.net/~pboal/papers/Informatica_Install/Informatica_Installation.html

  
Login to rate this answer.
s_subasini

Answered On : Nov 16th, 2006

View all answers by s_subasini

Hi Friends,If still your problem is not sloved then here is the solution.I also faced same problem during my installation of Informatica 7.1.1 recently.If the Informatica repository server is not starting the go to the Repository server setup change the the port no that min value writen on the below field ,at least more that the minimum value.and put your passward that is must.If your Informatica Server is not starting then workflow manager and configure the server there.Thanks & Regads,Subasini

  
Login to rate this answer.
rajesh

Answered On : Dec 8th, 2006

Guys,I too faced the same problem. But I resolved it. I guess there is some default firewall runnning which is stopping the services to start. Disable your firewall and then try to start the services. It should work. Its the way worked for me.BYeerajesh

  
Login to rate this answer.

This is for Informatica 7.1.3 installation1) Click launch.exe ( I mean setup file of informatica)2) Select powercenter for windows3) Give product key of license.txt file from new license key folder4) Configuring repository servera) Provide a name for your repository server.b) Provide password for administering repositoryc) Provide license keys.d) After this restart windows. Because we must restart windows before running informatica repository server.e) Start repository server(pmrepserver) in Control panel --> Administrative tools --> Servicesf) Check whether it is running or not Control panel --> Administrative tools -->Event Log Viewer--> pmrepserver properties5) Creating repositoryGo to repository server administrator console.a) register new repository server with hostname and port number.b) when configuring repository we have to provide connection stringThat is native connection string to connect to the database.When we install oracle it will create a connection string whose name is same as Service name(SID). We have to provide that name for connection string while configuring repository.c) create a database user by the following command in SQL plus. Create user identified by ; Grant dba to ;6) To configure the PowerCenter Server or Informatica server on Windows: a)In server tab give server name: User defined give host name: type hostname in command prompt to get this.b)in repository tabgive repository name: name of the repository you creaeted username:password:hostname:c)In repository server tabRepository server name: name of the repository server you configured Administrator password:Start the informatica server in Control panel --> administrative tools -->service --> pmserverd)provide license keys.7) Registering informatica server in Workflow manager Give pmserver name and informatica server installation directory.Please contact me at neeru.satya2005@gmail.com , i am glad to discuss informatica

  
Login to rate this answer.
power center

Answered On : Mar 6th, 2007

Check the exact error message in the even viewer log for the pmserver entry(navigate using settings--> control pannel-->Admin tools-->eventviewer.Probably this is relating to the port number. Change the port number to the one between max and min port number.Check the Administrator password.If you can't do let me know again.

  
Login to rate this answer.
anund

Answered On : Mar 20th, 2007

Hi,your tip worked for me...changed the port no. and now the service is up and running...thx:)

  
Login to rate this answer.
vizaik

Answered On : Mar 31st, 2007

View all answers by vizaik

guys n gals,please install xp-sp2 and then oracle 10g, then continue the informatice steps.  you won't get that type of problems.once i also got the same problem, then i reinstalled and got rid of the problemthanq

  
Login to rate this answer.
SUDHEER

Answered On : Apr 3rd, 2007

Try to re-install software once again and check the configuration weather you have given proper information or not.

  
Login to rate this answer.
uday

Answered On : Apr 16th, 2007

I think, the problem is like you have installed and configured both server and repository manager, then you are trying to start the informatica and repository manger sevices, at that time sevices get started and stopped immediately by giving message like no work is assinged to server If that is the problem, you may have configured the informatica server with diffenrent repository name, user and password and in repository admin console you are trying to configure the repository for other username,If that is not the problem, there may be problem with host name (may not matching) (Localhost/comp.name/ip address)

  
Login to rate this answer.
Puli Ramesh

Answered On : Apr 25th, 2007

  
Login to rate this answer.
balajier82

Answered On : Apr 29th, 2007

View all answers by balajier82

Dear Nagesh and Priya, I got the complete solution for your queries. I too had the same problem for the last one week, one of my friend provided me the step by step process on configuring the things correctly in informatica. Now the issue is fixed. All the credit goes to my friend.I got the word document (54 pages)with screen shots and step by step instruction, but I don't find any option to attach the file in this forum. Please let me know how to attach the file at the earliest. Probably this document will be a key solution for the all those who come with the same problem.The document contains the configuration procedure and a sample excercise.RegardsG.R

  
Login to rate this answer.
sreekanth

Answered On : May 8th, 2007

I am seeing most of the people are facing the same problem.
In Informatica server setup check these things :
1. Check your user id & password, connecting string & hostname etc...
somewhere you may missed in repository.
2. Check your default IP in your system, in server you have to give the same

ex :127.0.0.1 under TCP/IP host address.
(to check IP in your system start -> run -> cmd enter -> ipconfig you will get
your system IP address)
3 Add your licenses correctly.

In workflow manager
1. Server which you created name should match with server name given in
server setup.
2. Make sure you are getting your system IP in server, if not click resolve IP
address
3. Disconnect your internet connection if connected .
4. Assign your server to the desired folders and start now

Regards
Sreekanth

  
Login to rate this answer.
rajesh

Answered On : May 10th, 2007

Informatica 7.1 only supports Windows 2000 not does not support Windows XP. so you first uninstall XP and with Windows 2000 You can start the services OLAP agent, TNS and Client and Informatica repository agent and finally Informatica.

  
Login to rate this answer.
girish_Wankhede

Answered On : May 27th, 2007

Hi nagesh,I would suggest you to install Server2000 with service pack 4...& I ams ure you will not have these problems again...& one more thing don't go for 10g better go for 9i for windows platform & select 'Data warehousing' instead of selecting general purpose application..it works well...all the best    Girish

  
Login to rate this answer.
pandu

Answered On : Jul 26th, 2007

This problem occurs when the server is not configured or it has not worked to process so just go to Informatica work-flow manger and is server tab, click on configure and follow the steps.

  
Login to rate this answer.
smaru2004

Answered On : Aug 1st, 2007

Hello,These are my suggestions:1. Make sure Firewall is OFF and internet is ON. 2. Get your computer's full name and ip address after restarting the computer3. Go to Start-Programs-Informatica Power Center- Workflow manager - Server (from the menu) - Server configuration - Check whether you have your server name there or not. If yes, edit - go to row where it says "computer or host name" , you will have a web addresss, delete that and enter your ip address and then hit the button resolve address, it should be same as you entered. but it will change the ip address to your computer name.if xyz is your computer name thenit should look like this (before) Computer name : xyz.xyz.com ipaddress : 127.0.0.1enter your ip address at the web address spot and hit resolve ipaddress button it should change to (after) Computer name : xyz ipaddress ###.###.#.#Now close the workflow monitor, go to workflow manager, enter your admin password - right click the server - and click run monitor - it should say connected .. boom ...Do not change any port settings or Operating systems etc.it should work everywhere.Thanks. hope this helps.

  
Login to rate this answer.
Omkar

Answered On : Aug 2nd, 2007

Install Win XP Professional or Win2k Server. It will work properlyOmkar

  
Login to rate this answer.
smaru2004

Answered On : Aug 2nd, 2007

Hello all,Please do not waste time in XP prof or any other editions.Should work with XP Home. 100% positive.Spend some time in configuration which will be useful for you. or else follow the steps I have given before. SHOULD WORK.Thanks.

  
Login to rate this answer.
vikram

Answered On : Aug 5th, 2007

HI,Pls goto the event viewer and check the Problem. If you cant clear the problem. Un install the Informatica clear the registry and install it.

  
Login to rate this answer.
asandy1234

Answered On : Aug 5th, 2007

View all answers by asandy1234

Hi guys,I had the same problem during installation. I could be because ur antivirus is blocking the running of repository server  Try to stop the antivirus and run again . In my case I had to uninstall it.Anand

  
Login to rate this answer.
ande

Answered On : Aug 6th, 2007

Hi Priya,Just give host name as your computer name while configure informatica server.Regards,Ande

  
Login to rate this answer.
mufti

Answered On : Aug 17th, 2007

Check if you have installed some anti-virus/anti-spam softwares in your pc. Some of this softwares does not allow the repository server from starting. Uninstalled the softwares and try starting the repository server service.

  
Login to rate this answer.
tabrais

Answered On : Sep 6th, 2007

Change operating system. Informatica does not support any home edition operating system.

  
Login to rate this answer.
tabrais

Answered On : Sep 6th, 2007

You need database installed in your PC to connect it to repository. Without database you cannot start repository.

  
Login to rate this answer.
venu adavelly

Answered On : Sep 17th, 2007

Here is 3 tips You need to select suitable OS, Win2000, XP ProfessionYou need to create a folder for bad file and alocate saficiant shared memoryMain problem is OS, Windows 2000 is good for InformaticaVenu Adavelly

  
Login to rate this answer.
Kalaiarasan

Answered On : Sep 17th, 2007

I understand from your blogs that you people are experiencing an issue with Informatica Repository Service not running permanently when you start it. For this, I suggest you to first configure Informatica Repository Server correctly. This mistake can occur when you not properly given the 'server name' and 'TCP/Host name'. If this still occurs, this issue can occur if the repository service is not registered in registry. So, I suggest you to try unregister and register repository server service file.If still persists, uninstall ONLY Repository server.

  
Login to rate this answer.
jagadeeswari

Answered On : Oct 2nd, 2007

I also got same problem, I tried like this first stop repository manager and again start the repository manager and repository.

  
Login to rate this answer.
kishore

Answered On : Oct 29th, 2007

First choose windows nt server ,sp4,internet exp 6 then start installationit will create repository.before this install oracle9i and create user with ur name password with ur name.then start services.they start.if you got problem mail me

  
Login to rate this answer.
tmalik79

Answered On : Nov 19th, 2007

View all answers by tmalik79

Informatica repository name placed in 2 different places. 1) Server-->Informatica server setup. 2) Client-->Informatica Repository console(Here we generally create repository name and start the repository)Both the places Repository name should be same other wise when you try to start Repository service it will be stoped automatically.

  
Login to rate this answer.
suvashis

Answered On : Dec 12th, 2007

View all answers by suvashis

Hi some times i faced this type of problem due to automatic change of IP address in server config ....soln:priya go to workflow manager-->server confign--> check ur IP address if it is changed then click on RESOLVE button.and start informatica in windows service.thank u..suvashis

  
Login to rate this answer.
ksm_mohanta

Answered On : Feb 11th, 2008

View all answers by ksm_mohanta

If u ve installed oracle forms & reports then uninstall it.again reinstall informatica.give the port no.correct

  
Login to rate this answer.
vskogirala

Answered On : Feb 18th, 2008

View all answers by vskogirala

Hai priya,first u answer me about whether u r facing problems from informatica server or informatica repository serverif it is from informatica server the solution is 1st u have to start the informatica repository server and then informatica server other wise i mean if u do in reverse server could not be started it will be stopped if u r not starting repository server u have to configure it againok  if u have any doubts mail me at vskogirala@gmail.com

  
Login to rate this answer.
pal.amol

Answered On : Feb 26th, 2008

View all answers by pal.amol

Hello All, I faced same problem while installing the inforamtica powercenter 7.1.1 for the first time but my friend showed me and then took screenshots.  See now first thing you need to install inforamatica, config inforamtica server then repository server. then give perticular port number you can give hostname as your name if it is training and port number 9999 as it will be easy to identify then you need create repository but first dont forget to start the repository server .Ok now you have to go to repository manager create the repository and start the repository for this your db means oracle should be started already.   then in the workflow manager create the connection for the relation source in connections tab if it is relational otherwise other. then create repository server and give it perticular hostname resolve the server , give the path to perticular session logs etc.At the end you need to assign the server and select the required or all workflows for the perticular server.start the informatica server then test it is working correct or not because till the server will not be configured correctly informatica server services will not start though repository server service started.if any issue pal.amol@gmail.com

  
Login to rate this answer.
arunmidturi

Answered On : Apr 10th, 2008

View all answers by arunmidturi

HI I had the same problem plazz tell what you did to the probel.

  
Login to rate this answer.
adilshariff

Answered On : Jul 1st, 2008

View all answers by adilshariff

After installing  Informatica 7.1 ,Goto Start>>Programs>>Administrative Tools>>Services>>Informatica Repository Service>>Right Click and Start.If ,this doesn't start then,Goto Start>>Programs>>Administrative Tools>>Event Viewer>>Application Log>>Right Click on Error and then Select Properties.Here , you will know, what's the problem.Please send us the problem to resolve this issue

  
Login to rate this answer.
mrmanikandan81

Answered On : Mar 31st, 2009

View all answers by mrmanikandan81

First check you install informatica properly or not, once again reinstall the Informatica software, then goto the services in that right click the Informatica Repository Server in that refresh option is there, click that one, if the started service is stopped means, you didn't install Informatica properly, and also check you install any Java or Dot Net or Apache server or any server means you disable the services, then it works try it.

  
Login to rate this answer.
annusha

Answered On : Jul 12th, 2010

View all answers by annusha

Even I too got the same problem but it was solved...can you people try once...go to Workflow Manager|Server|Edit|Resolve ServerApply and click OkNow You can start your services....it will be connected....Thank you

  
Login to rate this answer.
Chakradhar

Answered On : Nov 2nd, 2011

I am also facing the same problem. Can you please tel me how to change the port number and all.

  
Login to rate this answer.
Srikanta

Answered On : Nov 11th, 2011

In order to up your IRS, please follow up the guidelines:-

1) Create a database, if u have already DB exist, then u can go with the same.

2) Create two db users, give admin privilege to those users.

3) The go with the normal Informatica installation steps, and please do configure your IRS with the respective db users.

4) Start the informatica Integration service, and then try with IRS. It must work out if u followed up the steps mentioned.

Any issue/questions, kindly post me back.

Regards,
Srikant

  
Login to rate this answer.
k.praveenkumar

Answered On : Dec 6th, 2011

Software could be corrupted or has attacked with Virus,
Re-install and if the problem persist then you change the OS and try Informatica, it may work.

  
Login to rate this answer.

Give your answer:

If you think the above answer is not correct, Please select a reason and add your answer below.

Related Open Questions

Ads

Connect

twitter fb Linkedin GPlus RSS

Ads

Interview Question

 Ask Interview Question?

 

Latest Questions

Interview & Career Tips

Get invaluable Interview and Career Tips delivered directly to your inbox. Get your news alert set up today, Once you confirm your Email subscription, you will be able to download Job Inteview Questions Ebook . Please contact me if you there is any issue with the download.