How can we configure dhcp features in an switch?

Editorial / Best Answer

Answered by: Kalyan Raghavan

  • Jan 28th, 2006


DHCP is only available on newer IOS-based switches. For example, Catalyst 3550 and 3750 offer DHCP.

Let us take Cisco 2611 router running IOS12.2

To begin, connect the router's Ethernet port to a switch, and connect the switch to a laptop, which will serve as the DHCP client.

To configure Cisco IOS DHCP, follow these steps, which include sample commands:

  1. Configure an IP address on the router's Ethernet port, and bring up the interface. (On an existing router, you would have already done this.)

Router(config)# interface ethernet0/0
Router(config-if)#ip address 1.1.1.1 255.0.0.0
Router(config-if)# no shutdown

  1. Create a DHCP IP address pool for the IP addresses you want to use.

Router (config)# ip dhcp pool mypool

  1. Specify the network and subnet for the addresses you want to use from the pool.

Router(dhcp-config)# network 1.1.1.0 /8  

  1. Specify the DNS domain name for the clients.

Router(dhcp-config)#domain-name mydomain.com

  1. Specify the primary and secondary DNS servers.

Router(dhcp-config)#dns-server 1.1.1.10 1.1.1.11

  1. Specify the default router (i.e., default gateway).

Router(dhcp-config)#default-router 1.1.1.1

  1. Specify the lease duration for the addresses you're using from the pool.

Router(dhcp-config)#lease 7

  1. Exit Pool Configuration Mode.

Router(dhcp-config)#exit

This takes you back to the global configuration prompt. Next, exclude any addresses in the pool range that you don't want to hand out.

For example, let's say that you've decided that all IP addresses up to .100 will be for static IP devices such as servers and printers. All IP addresses above .100 will be available in the pool for DHCP clients.

Next, enter the ipconfig /renew command on the laptop to receive an IP address. After you have the IP address, enter the ipconfig /all command.

Showing Answers 1 - 1 of 1 Answers

Kalyan Raghavan

  • Jan 28th, 2006
 

DHCP is only available on newer IOS-based switches. For example, Catalyst 3550 and 3750 offer DHCP.

Let us take Cisco 2611 router running IOS12.2

To begin, connect the router's Ethernet port to a switch, and connect the switch to a laptop, which will serve as the DHCP client.

To configure Cisco IOS DHCP, follow these steps, which include sample commands:

  1. Configure an IP address on the router's Ethernet port, and bring up the interface. (On an existing router, you would have already done this.)

Router(config)# interface ethernet0/0
Router(config-if)#ip address 1.1.1.1 255.0.0.0
Router(config-if)# no shutdown

  1. Create a DHCP IP address pool for the IP addresses you want to use.

Router (config)# ip dhcp pool mypool

  1. Specify the network and subnet for the addresses you want to use from the pool.

Router(dhcp-config)# network 1.1.1.0 /8    

  1. Specify the DNS domain name for the clients.

Router(dhcp-config)#domain-name mydomain.com

  1. Specify the primary and secondary DNS servers.

Router(dhcp-config)#dns-server 1.1.1.10 1.1.1.11

  1. Specify the default router (i.e., default gateway).

Router(dhcp-config)#default-router 1.1.1.1

  1. Specify the lease duration for the addresses you're using from the pool.

Router(dhcp-config)#lease 7

  1. Exit Pool Configuration Mode.

Router(dhcp-config)#exit

This takes you back to the global configuration prompt. Next, exclude any addresses in the pool range that you don't want to hand out.

For example, let's say that you've decided that all IP addresses up to .100 will be for static IP devices such as servers and printers. All IP addresses above .100 will be available in the pool for DHCP clients.

Next, enter the ipconfig /renew command on the laptop to receive an IP address. After you have the IP address, enter the ipconfig /all command.

  Was this answer useful?  Yes

Give your answer:

If you think the above answer is not correct, Please select a reason and add your answer below.

 

Related Answered Questions

 

Related Open Questions