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1.0 INTRODUCTION

Mercury Quick Test Professional 8.0 provides the industry’s best solution for functional test and regression test automation - addressing every major software application and environment. This next-generation automated testing solution deploys the concept of Keyword-driven testing to radically simplify test creation and maintenance. Unique to Quick Test Professional’s Keyword-driven approach, test automation experts have full access to the underlying test and object properties, via an integrated scripting and debugging environment that is round-trip synchronized with the Keyword View. 
Quick Test Professional 8.0 satisfies the needs of both technical and non-technical users. It enables you to deploy higher-quality applications faster, cheaper, and with less risk. It empowers the entire testing team to create sophisticated test suites with minimal training. 

Advantages:
• Empower the entire team to create sophisticated test suites with minimal training 
• Ensure correct functionality across all environments, data sets, and business processes 
• Fully document and replicate defects for developers, enabling them to fix defects faster and meet production deadlines 
• Easily regression-test ever-changing applications and environments 
• Become a key player in enabling the organization to deliver quality products and services, and improve revenues and profitability 

New Features in QTP 8.0

FEATURE USE
Keyword View Lets you easily build and maintain tests without writing VBScripts
Auto-Documentation Provides improved test clarity and the ability to view test steps in plain English
Step Generator Allows you to quickly insert custom-built functions into your tests
Enhanced Expert View Provides greater efficiency when generalizing test components
Action Parameters Allows you to generalize testing actions for greater reusability
Custom Reports Enables you to create custom reports for your unique needs
Unicode Support Lets you test global deployments of your enterprise applications






2.0 RECORDING A SESSION

QuickTest records the operations we perform, displays them as steps in the Keyword View, and generates scripts in the expert view. Each test in Quick test includes a single action. Multiple actions can be included when needed. 

• Before recording a test see to that all other browsers are closed. Choose how to open the application. This can be done as follows:
Go to Test->Record & Run Settings->web.
If the page is already open select the ‘Record and run on any open web browser’ option. If you want to open the page automatically select the ‘Open the following browser when record and run session begins’ option and set the Url of the page you want to record.
• Click the Record button or choose Test > Record.
• Navigate through the application or Web site. QuickTest records each step performed and displays it in the Keyword View and Expert View. 
• When you complete your recording, click the Stop button or choose Test > Stop. 
• Click the Save button to save the test.
Example:
While recording the home page of Google the following code is 
generated.
Browser("Google").Page("Google").WebEdit("Search").Set "QTP "
Browser("Google ").Page("Google").WebEdit("Search").Submit
Browser("Google").Page("GoogleSearch: QTP").Link("QTP").Click
Browser("Google ").Page("QTP").Sync
RECORDING MODES

Quick test supports the following recording modes:
a. Normal: recognizes the objects in the application irrespective of their location in the screen.
b. Analog: records the exact keyboard and mouse operations with respect to the screen coordinates or the application window.
c. Low level: records any object irrespective of support from QTP. Recognizes all run time objects as windows objects. It is used when an object is not identified by Quick test.
By default the normal recording mode is enabled.

3.0 RUNNING A SESSION

When you run a test, QuickTest performs the steps you recorded on the application.

• The Run option can be used to run the test from start to end.

• The Run from Step option in the Test menu is used to run the test from a selected step to the end of the current action, if running from the Expert View, or to the end of the test , if running from the Keyword View. Thus it enables us to check a specific part of the application or to confirm that a certain part of the test runs correctly. 

• The Update Run option in the Test menu is used to update the Active screens, Checkpoints and the test object descriptions. While recording, Quick Test saves the snapshots of the application as Active screens which can be used later to set Checkpoints and output values.


• The Pause option in the Debug menu is used to temporarily suspend the run. To resume running a paused test, click the Run button.

• The StepInto(F11) option in the Debug menu is used to run the current line of the test.


• The Insert\Remove Breakpoint(F9) option in the Debug menu is used to stop a test run at a pre-determined place in a test. A breakpoint is indicated by a red-colored hand in the left margin of the test window. The test run is paused when it reaches the breakpoint, before executing the step. You can examine the effects of the test run up to the breakpoint, make any necessary changes, and then continue running the test from the breakpoint. 

• The DebugViewer option in the View menu is used to view, set, or modify the current value of objects or variables in the test,when a test stops at a breakpoint.

After a test run, the results are displayed in the Test Results window.If the window is not already open choose Test->Results.The Test result tree can be collapsed and expanded. Iterations, actions, and steps that contain checkpoints are marked Passed or Failed in the bottom right part of the Test Results window and are identified by the icon or in the tree pane. 

To add details in the Test results window Reporter event is used. The following line of code can be used.

Reporter.ReportEvent 0, Search, “Search Successful"

The first argument (0 or 1) represents the Event status.0 and 1 represent pass and fail respectively. The second argument indicates the step name and the third gives details about the executed test.

4.0 ACTIONS

A test is composed of actions or logical sections. The steps we add to the test are added within the test’s actions. By default, each test begins with a single action. Dividing a test into actions helps us to streamline the testing process. When we run a test with multiple actions, the Test Results are divided by actions so that we can view the detailed results for each action individually. Each action has its own sheet in the Data Table so that we can insert data that applies only to that action.

Actions can be of three types:
• Non-re-usable: Action can be used in the local test, only once.
• Reusable: Action can be used in the local test, multiple times.
• External: These are reusable actions created in another test. This can be of two types. If a call to an external action is used the action is read only in the calling test. But, any existing action can be inserted as a copy of the original action. In this case, we can modify this copy of the external action in the calling test. 


Actions on Quick Test Window (Keyword View)

Actions Tool Bar contains buttons and a list of actions, enabling us to view the details of an individual action or the entire test flow. The test flow displays the overall flow of the test with all the actions in the test.

There are two buttons on the Actions Tool Bar, i.e. BACK and SHOW, as shown below.

Actions List Back Show

The Action Tool Bar will be visible, only when, we have one or more external/reusable actions in our  Action to display( Tool Bars(test. If it is invisible, use View it.

4.1 Creating a new action

1) Click the step after which you want to insert the new action.

2) Choose Insert > New Action or click the New Action 
button. The Insert New Action dialog box opens. (In QTP 8.0, Insert Call to New Action)

3) Type a new action name or accept the default name.

4) Add a description of the action. 

5) Select Reusable Action to make it reusable. This can be 
modified at a later time in the Action properties dialog box.

6) To insert a new action at the end of the test, check the At the end of the test checkbox. To insert the new action within the action of the currently selected step, select After the current step.

7) Click OK.

4.2 Inserting an existing action

We can insert an existing action by inserting a copy of the action, or by inserting a call to the original action.
a) Inserting calls to an action makes it easier to maintain tests, because when an object or procedure in the application changes, it needs to be updated only once, in the original action.

b) When we insert a copy of an action into a test, the action is copied in its entirety, including checkpoints, parameterization, and the corresponding action tab in the Data Table. The action is inserted into the test as an independent, non-reusable action (even if the original action was reusable). Once the action is copied into the test, we can add to, delete from, or modify the action. Any changes we make to this action after inserting it affect only this action, and changes to the original action do not affect the inserted action. We can insert copies of both reusable and non-reusable actions.

Select an existing action, and choose: 
Call to Copy of an action / Call to(Insert  select(Use the Browse button to choose the action(Existing Action as required   Click OK.(the location

4.3 Nesting Actions

Running an Action within an action is nesting. The following are the uses of nesting actions.

• Helps maintaining the modularity of the test
• Help running one action or another based on the results of a conditional statement
• To insert a nested action, follow the same procedure for inserting a new Action, with, select after the current step as 6th step.

4.4 Splitting Actions

To split an existing action:
1) Select the step with which the new action should begin.
Split(
2) Choose Step Action. The following window appears:






• If we select ‘Independent of each other’ option: it creates 2 independent actions, with second action beginning with the selected step. 
• If we select ‘Nested’ option: It creates two actions, with first one calling the second. (A Parent-Child relationship).

3) We can also change the Names and Descriptions of these actions.

4.5 Exiting an Action

There are three types of Exit Action statements:

• ExitAction - Exits the current action, regardless of its iteration attributes.
• ExitActionIteration - Exits the current iteration of the action.
• ExitRun - Exits the test, regardless of its iteration attributes.
• ExitGlobalIteration - Exits the current global iteration.

5.0 OBJECT MANAGEMENT 

Quick Test identifies objects of two types
• Test Objects: Objects in the test that represent objects in the application or website that are created and maintained by QTP.
• Run Time Objects: Objects in the application that are created and maintained by the Browser.
Three object management tools are available to maintain both the test and runtime objects in the test.

5.1 Object Identification

It is used to set the properties used to identify an object. Each object has mandatory and assistive properties which are used to identify them. For example, from the figure below, the mandatory properties used to identify an ActiveX button object are caption and progid. Thus an ActiveX button is always identified using these two properties. In case these properties are not enough for identifying the object Quick Test uses the assistive properties to do the same. We can modify these properties using the Add\Remove button. Smart Identification is used to identify the object if the learned properties are not sufficient. 

5.2 Object Repository

All objects recorded for the test are stored in the repository. The Object Repository displays all objects in the current action or the entire test. The Object Repository can be used to view or modify the properties of any object in the reposirory or to add new objects to the repository. An object in the application can be highlighted using the Highlight option. A temporary frame appears around the object causing it to flash. But the application must be open and the object should be visible in the page. The object spy can also be accessed from the Repository.

Set the object repository path from Test->Settings->Resource Tab. Select the repository file with the extension .tsr. If the repository file is not available create a file with extension .tsr. The repository path must be set before starting recording.
The Object Repository can be Per Action or Shared. 
• The shared repository can be used by multiple actions of the same test or by actions from different tests. Test object properties are prone to frequent updation. While adding existing actions, we can copy an action using the same Object Repository and Call actions using the same Object Repository, or Object Repository per action mode
• Per Action object repository is used by one or very few tests.Test object properties are modified less frequently.While adding existing actions, if we are using different object repositories for different actions (One repository per action) then we can copy or call actions from tests using Object Repository per Action mode.

5.3 Object Spy 

It can be used to view the properties and values of an object in any open application. Click the pointing hand to select the object in the application. The object’s properties (Test object properties and Run-Time object properties) and methods can be identified. The object’s hierarchy tree is also displayed. To perform other events such as mouse clicks or window focus hold the CTRL key.

6.0 CHECKPOINTS

A checkpoint is a verification point that compares a current value for a specified property with the expected value for that property. Thus it ensures proper functionality of the objects in the application. When you add a checkpoint for an object a statement containing Check Checkpoint is added in the Expert view. Checkpoints can be added in the following ways.

• During Recording: In the Keyword View or Expert View, choose Insert
->Checkpoint option to select a type of checkpoint and select the object for which the checkpoint is to be added.
• During Editing: Right click the object in the Active screen and select the type of checkpoint to be added.

After selecting the object, add the property that is to be checked. For example, for a standard checkpoint on a radio button for the property ‘selected’ checks whether the radio button is selected or not. Checkpoints can also be placed in the Keyword view. Right click the object in the keyword view and insert the required checkpoint.

Example:

Consider inserting a checkpoint for the Search textbox in the Home page of Google. The following code is generated.

Browser ("Google").Page ("Google").WebEdit ("Search").Check CheckPoint ("Search")

If you want to retrieve value from the checkpoint, use parenthesis around the checkpoint argument.

TYPES OF CHECKPOINT

TYPES DESCRIPTION


Standard CheckPoint

It checks the property value of an object in your application or Web page. It checks a variety of objects such as buttons, radio buttons, combo boxes, lists, etc.

Image CheckPoint

It checks the value of an image in the application. We can create an image checkPoint by inserting a standard checkPoint on the image object.

Bitmap CheckPoint

It checks an area of the application as a bitmap.To create a bitmap checkpoint of multiple objects, select the highest level object that includes all the objects to include in the bitmap checkpoint.


Text CheckPoint

It checks whether the text string is displayed in the appropriate place in your application or on a Web page

Text Area CheckPoint

It checks whether the text string is displayed within the defined area in the application. If the area defined is associated with more than one object, the Object Selection-Text Area Checkpoint Properties dialog box opens.

Table CheckPoint

It checks the information within a table or the table itself. The row or column values can also be checked.

Accessibility CheckPoint

It identifies areas of the Web site that do not conform to the World Wide Web Consortium (W3C) Web Content Accessibility Guidelines.

Page CheckPoint 

It checks whether the page is displayed correctly and gives information like number of links, number of images and load time of the page

Database CheckPoint
 
It checks the contents of a database accessed by the application

XML CheckPoint

It checks the data content of XML documents in XML documents in the application

7.0 OUTPUT VALUES

Output Value is used to retrieve the current value of any object in the application and stores it in a specified location. Output values can be added in the following ways

• During Recording: In the Keyword View or Expert View, choose Insert -> Output Value and select the type of output value and the object for which the value is to be outputted.

• During Editing: Right click the object in the Active screen and select the type of output value to be added.If the location clicked is associated with more than one object, then the Object Selection - Output Value Properties dialog box opens. From here select the required object.

Types of Output values

We can create the following categories of output values: 
• Standard Output Values: to output the property values of most objects like editbox,button,radio button,list box,etc.
• Text Output Values: to output text strings displayed in the application. When creating a text output value, we can output a part of the object's text. The text before and after the output text can also specified.
• Text Area Output Values: to output text strings displayed within a defined area of the application. We can also output a part of the object’s test. 
• Database Output Values: to output the contents of database cells, based on the results of a query on the database. We can create output values from the entire contents of the result set, or from a part of it.
• XML Output Values: to output the values of XML elements and attributes in XML documents.


Example
Browser("Google").Page("Google").WebEdit("Search").Set "QTP"

Browser("Google").Page("Google").WebEdit("Search").Output CheckPoint("Search")

Browser("Google").Page("Google").WebEdit("Search").Submit

Browser("Google ").Page("Google Search: QTP").Link("QTP").Click

Browser("Google ").Page("QTP").Sync

8.0 PARAMETERIZATION

A parameter is a variable that is assigned a value from an external data source at run time. We use parameterization when we want to change the value of properties at run time. Parameterization can be done in three ways using Quick Test.
• Datatable
• Environment variables
• Random numbers

A property of an object can be parameterised from the object repository.Select the property to be parameterised and check the Parameter option from the configure vlue frame and enter the value in the datatable column.

8.1 DataTable Parameters

The test runs once for each line of data in the DataTable. Each iteration takes a different value from the datatable. To run selected rows in the datatable choose the Run tab from Test->Settings and specify an option in the Datatable iterations frame.

Example
Consider parameterising the search string in the home page of Google.Each time you want to search for a different string. Enter the search string in the datatable and change the code as follows
Browser("Google").Page("Google").WebEdit("Search").Set
Datatable.Value("SearchString")

Browser("Google").Page("Google").WebEdit("Search").Submit

The datatable contains the searchstrings for search. The datatable has two rows and thus the test runs for two iterations.We can import data for the datatable from an external source such as Excel. Choose the resources tab from Test->Settings and select Other location in the Datatable frame and specify the path of the Excel file.

8.2 Environment variable Parameters

The Environment variables can have Quick Test generated values or values supplied from external files. We can add environment variables from Test->Settings->Environment tab. Choose User-defined from the variable type. Click New to create your own internal variables or Click Export to retrieve values from external sources.

8.3 Random number Parameters
It enables us to use random numbers as values in the test. We can specify the range from which the random number is generated. By default, the random number range is between 0 and 100.
1. What is QTP?
Quick Test Pro is a graphical interface record-playback automation tool. It is able to work with any web, java or windows client application. Quick Test enables you to test standard web objects and ActiveX controls. In addition to these environments, Quick Test Professional also enables you to test Java applets and applications and multimedia objects on Applications as well as standard Windows applications, Visual Basic 6 applications and.NET framework applications

2. What are the Features & Benefits of Quick Test Pro (QTP 8.0)? 
Operates stand-alone, or integrated into Mercury Business Process Testing and Mercury Quality Center. Introduces next-generation zero-configuration Keyword Driven testing technology in Quick Test Professional 8.0 allowing for fast test creation, easier maintenance, and more powerful data-driving capability. Identifies objects with Unique Smart Object Recognition, even if they change from build to build, enabling reliable unattended script execution. Collapses test documentation and test creation to a single step with Auto-documentation technology. Enables thorough validation of applications through a full complement of checkpoints.

3. How to handle the exceptions using recovery scenario manager in QTP? 
There are 4 trigger events during which a recovery scenario should be activated. A pop up window appears in an opened application during the test run: A property of an object changes its state or value, A step in the test does not run successfully, An open application fails during the test run, These triggers are considered as exceptions.You can instruct QTP to recover unexpected events or errors that occurred in your testing environment during test run. Recovery scenario manager provides a wizard that guides you through the defining recovery scenario. Recovery scenario has three steps: 1. Triggered Events 2. Recovery steps 3. Post Recovery Test-Run

4. What is the use of Text output value in QTP?
Output values enable to view the values that the application talks during run time. When parameterized, the values change for each iteration. Thus by creating output values, we can capture the values that the application takes for each run and output them to the data table.

5. How to use the Object spy in QTP 8.0 version?
There are two ways to Spy the objects in QTP: 1) Thru file toolbar, In the File Toolbar click on the last toolbar button (an icon showing a person with hat). 2) True Object repository Dialog, In Object repository dialog click on the button object spy. In the Object spy Dialog click on the button showing hand symbol. The pointer now changes in to a hand symbol and we have to point out the object to spy the state of the object if at all the object is not visible. or window is minimized then, hold the Ctrl button and activate the required window to and release the Ctrl button.

6. How Does Run time data (Parameterization) is handled in QTP?
You can then enter test data into the Data Table, an integrated spreadsheet with the full functionality of Excel, to manipulate data sets and create multiple test iterations, without programming, to expand test case coverage. Data can be typed in or imported from databases, spreadsheets, or text files.

7. What is keyword view and Expert view in QTP?
Quick Test’s Keyword Driven approach, test automation experts have full access to the underlying test and object properties, via an integrated scripting and debugging environment that is round-trip synchronized with the Keyword View. Advanced testers can view and edit their tests in the Expert View, which reveals the underlying industry-standard VBScript that Quick Test Professional automatically generates. Any changes made in the Expert View are automatically synchronized with the Keyword View.

8. Explain about the Test Fusion Report of QTP? 
Once a tester has run a test, a Test Fusion report displays all aspects of the test run: a high-level results overview, an expandable Tree View of the test specifying exactly where application failures occurred, the test data used, application screen shots for every step that highlight any discrepancies, and detailed explanations of each checkpoint pass and failure. By combining Test Fusion reports with Quick Test Professional, you can share reports across an entire QA and development team.

9. Which environments does QTP support?
Quick Test Professional supports functional testing of all enterprise environments, including Windows, Web,..NET, Java/J2EE, SAP, Siebel, Oracle, PeopleSoft, Visual Basic, ActiveX, mainframe terminal emulators, and Web services.

10. Explain QTP Testing process? 
Quick Test testing process consists of 6 main phases:

11. Create your test plan 
Prior to automating there should be a detailed description of the test including the exact steps to follow, data to be input, and all items to be verified by the test. The verification information should include both data validations and existence or state verifications of objects in the application.

12.Recording a session on your application 
As you navigate through your application, Quick Test graphically displays each step you perform in the form of a collapsible icon-based test tree. A step is any user action that causes or makes a change in your site, such as clicking a link or image, or entering data in a form.

13.Enhancing your test 
Inserting checkpoints into your test lets you search for a specific value of a page, object or text string, which helps you identify whether or not your application is functioning correctly. NOTE: Checkpoints can be added to a test as you record it or after the fact via the Active Screen. It is much easier and faster to add the checkpoints during the recording process. Broadening the scope of your test by replacing fixed values with parameters lets you check how your application performs the same operations with multiple sets of data. Adding logic and conditional statements to your test enables you to add sophisticated checks to your test.

14.Debugging your test
If changes were made to the script, you need to debug it to check that it operates smoothly and without interruption.

15. Running your test on a new version of your application
You run a test to check the behavior of your application. While running, Quick Test connects to your application and performs each step in your test.

16. Analyzing the test results 
You examine the test results to pinpoint defects in your application.

17. Reporting defects 
As you encounter failures in the application when analyzing test results, you will create defect reports in Defect Reporting Tool.

18. Explain the QTP Tool interface.
It contains the following key elements: Title bar, displaying the name of the currently open test, Menu bar, displaying menus of Quick Test commands, File toolbar, containing buttons to assist you in managing tests, Test toolbar, containing buttons used while creating and maintaining tests, Debug toolbar, containing buttons used while debugging tests. Note: The Debug toolbar is not displayed when you open Quick Test for the first time. You can display the Debug toolbar by choosing View — Toolbars — Debug. Action toolbar, containing buttons and a list of actions, enabling you to view the details of an individual action or the entire test flow. Note: The Action toolbar is not displayed when you open Quick Test for the first time. You can display the Action toolbar by choosing View — Toolbars — Action. If you insert a reusable or external action in a test, the Action toolbar is displayed automatically. Test pane, containing two tabs to view your test-the Tree View and the Expert View ,Test Details pane, containing the Active Screen. Data Table, containing two tabs, Global and Action, to assist you in parameterizing your test. Debug Viewer pane, containing three tabs to assist you in debugging your test-Watch Expressions, Variables, and Command. (The Debug Viewer pane can be opened only when a test run pauses at a breakpoint.) Status bar, displaying the status of the test

19. How does QTP recognize Objects in AUT?
Quick Test stores the definitions for application objects in a file called the Object Repository. As you record your test, Quick Test will add an entry for each item you interact with. Each Object Repository entry will be identified by a logical name (determined automatically by Quick Test), and will contain a set of properties (type, name, etc) that uniquely identify each object. Each line in the Quick Test script will contain a reference to the object that you interacted with, a call to the appropriate method (set, click, check) and any parameters for that method (such as the value for a call to the set method). The references to objects in the script will all be identified by the logical name, rather than any physical, descriptive properties.

20. What are the types of Object Repositories in QTP? 
Quick Test has two types of object repositories for storing object information: shared object repositories and action object repositories. You can choose which type of object repository you want to use as the default type for new tests, and you can change the default as necessary for each new test. The object repository per-action mode is the default setting. In this mode, Quick Test automatically creates an object repository file for each action in your test so that you can create and run tests without creating, choosing, or modifying object repository files. However, if you do modify values in an action object repository, your changes do not have any effect on other actions. Therefore, if the same test object exists in more than one action and you modify an object’s property values in one action, you may need to make the same change in every action (and any test) containing the object.

21. Explain the check points in QTP?
A checkpoint verifies that expected information is displayed in an Application while the test is running. You can add eight types of checkpoints to your test for standard web objects using QTP. A page checkpoint checks the characteristics of an Application. A text checkpoint checks that a text string is displayed in the appropriate place on an Application. An object checkpoint (Standard) checks the values of an object on an Application. An image checkpoint checks the values of an image on an Application. A table checkpoint checks information within a table on a Application. An Accessibilityy checkpoint checks the web page for Section 508 compliance. An XML checkpoint checks the contents of individual XML data files or XML documents that are part of your Web application. A database checkpoint checks the contents of databases accessed by your web site

22. In how many ways we can add check points to an application using QTP? 
We can add checkpoints while recording the application or we can add after recording is completed using Active screen (Note : To perform the second one The Active screen must be enabled while recording).

23. How does QTP identify objects in the application? 
QTP identifies the object in the application by Logical Name and Class.

24. What is Parameterizing Tests?
When you test your application, you may want to check how it performs the same operations with multiple sets of data. For example, suppose you want to check how your application responds to ten separate sets of data. You could record ten separate tests, each with its own set of data. Alternatively, you can create a parameterized test that runs ten times: each time the test runs, it uses a different set of data.

25. What is test object model in QTP?
The test object model is a large set of object types or classes that Quick Test uses to represent the objects in your application. Each test object class has a list of properties that can uniquely identify objects of that class and a set of relevant methods that Quick Test can record for it. A test object is an object that Quick Test creates in the test or component to represent the actual object in your application. Quick Test stores information about the object that will help it identify and check the object during the run session.

26. What is Object Spy in QTP? 
Using the Object Spy, you can view the properties of any object in an open application. You use the Object Spy pointer to point to an object. The Object Spy displays the selected object’s hierarchy tree and its properties and values in the Properties tab of the Object Spy dialog box.

27. What is the Diff between Image check-point and Bit map Check point?
Image checkpoints enable you to check the properties of a Web image. You can check an area of a Web page or application as a bitmap. While creating a test or component, you specify the area you want to check by selecting an object. You can check an entire object or any area within an object. Quick Test captures the specified object as a bitmap, and inserts a checkpoint in the test or component. You can also choose to save only the selected area of the object with your test or component in order to save disk Space. For example, suppose you have a Web site that can display a map of a city the user specifies. The map has control keys for zooming. You can record the new map that is displayed after one click on the control key that zooms in the map. Using the bitmap checkpoint, you can check that the map zooms in correctly. You can create bitmap checkpoints for all supported testing environments (as long as the appropriate add-ins are loaded). Note: The results of bitmap checkpoints may be affected by factors such as operating system, screen resolution, and color settings.

28. How many ways we can parameterize data in QTP?
There are four types of parameters: Test, action or component parameters enable you to use values passed from your test or component, or values from other actions in your test. Data Table parameters enable you to create a data-driven test (or action) that runs several times using the data you supply. In each repetition, or iteration, Quick Test uses a different value from the Data Table. Environment variable parameters enable you to use variable values from other sources during the run session. These may be values you supply, or values that Quick Test generates for you based on conditions and options you choose. Random number parameters enable you to insert random numbers as values in your test or component. For example, to check how your application handles small and large ticket orders, you can have Quick Test generate a random number and insert it in a number of tickets edit field.

29. How do u do batch testing in WR & is it possible to do in QTP, if so explain? 
Batch Testing in WR is nothing but running the whole test set by selecting Run Test set from the Execution Grid. The same is possible with QTP also. If our test cases are automated then by selecting Run Test set all the test scripts can be executed. In this process the Scripts get executed one by one by keeping all the remaining scripts in Waiting mode.

30. If I give some thousand tests to execute in 2 days what do u do? 
Adhoc testing is done. It Covers the least basic functionalities to verify that the system is working fine.

31. What does it mean when a check point is in red color? what do u do? 
A red color indicates failure. Here we analyze the cause for failure whether it is a Script Issue or Environment Issue or a Application issue.

32. What is Object Spy in QTP? 
Using the Object Spy, you can view the properties of any object in an open application. You use the Object Spy pointer to point to an object. The Object Spy displays the selected object’s hierarchy tree and its properties and values in the Properties tab of the Object Spy dialog box.

33. What is the file extension of the code file & object repository file in QTP? 
Code file extension is.vbs and object repository is.tsr

34. Explain the concept of object repository & how QTP recognizes objects?
Object Repository: displays a tree of all objects in the current component or in the current action or entire test (depending on the object repository mode you selected). We can view or modify the test object description of any test object in the repository or to add new objects to the repository. Quicktest learns the default property values and determines in which test object class it fits. If it is not enough it adds assistive properties, one by one to the description until it has compiled the unique description. If no assistive properties are available, then it adds a special Ordinal identifier such as objects location on the page or in the source code.

35. What are the properties you would use for identifying a browser & page when using descriptive programming? 
Name would be another property apart from title that we can use.

36. Give me an example where you have used a COM interface in your QTP project? 
com interface appears in the scenario of front end and back end. for eg:if you r using oracle as back end and front end as VB or any language then for better compatibility we will go for an interface. of which COM will be one among those interfaces. Create object creates handle to the instance of the specified object so that we program can use the methods on the specified object. It is used for implementing Automation(as defined by Microsoft).

37. Explain in brief about the QTP Automation Object Model.
Essentially all configuration and run functionality provided via the Quick Test interface is in some way represented in the Quick Test automation object model via objects, methods, and properties. Although a one-on-one comparison cannot always be made, most dialog boxes in Quick Test have a corresponding automation object, most options in dialog boxes can be set and/or retrieved using the corresponding object property, and most menu commands and other operations have corresponding automation methods. You can use the objects, methods, and properties exposed by the Quick Test automation object model, along with standard programming elements such as loops and conditional statements to design your program.

Faqs in QTP
1. What is Test Frame Work? 

2. How comfortable are you in VB Scripting? 

3. What is Description Object? 

4. What are SetToProperty, SetRoProperty, GetToProperty scripting? 

5. What is the difference between version 6.5 and 8.2? 

6. What is the difference between Normal mode and Fast mode? 

7. How do you invoke the application through QTP? 

8. How do you close the Task Manager through QTP? 

9. How will you load the object during run time? 

10. How will you handle the situation when object is not captured during record? 

11. What is test object? 

12. How QTP recognizes the objects stored in object repository 

13. What is post recovery scenario? 

14. What is reusable action and how the same can be implemented (process) 

15. How will u integrate oracle with QTP 

16. How QTP integrate with application 

17. What is object repository? 

18. What are all the fields present in object repository? 

19. What is smart identification? 

20. What are the mandatory properties for a text box (scenario?) 

21. What is Checkpoint? 

22. What is object? 

23. What are the properties of object? 

24. What is Action? 

25. What will be there in Keyword view and Expert View? 

26. What is regular expression how will u implement it 

27. Where the checkpoints are stored 

28. What is database checkpoint, how will u parameterize the database from separate data table 

29. How will u handle application crash using recovery scenario manager (Step By Step Process) 

30. What is Virtual Object? 

31. What is the difference between calling a function and reusing an action? 

32. How QTP support all types of applications (Platforms) 

33. What is the difference between application testing and product testing? 

34. What is throw object? 

35. What is Run-time Data? 

36. How will you enhance the script? 

37. Can objects recogonised without repository? 

38. Where did u automate in ur project 

39. Any challenge that faced in ur project 

40. Batch test,run action 

41. Purpose of automation 

42. Diff ways of parameterising 

43. Error handled other than recovery scenario manager 

44. Diff betw WR and QTP 

45. What kind of errors can b handled? 

46. How you used DDT in QTP? 

47. Difference between keyword driven test and DDT? 

48. How did you use regular expression in QTP and also in Win Runner? 

49. How do you learn the object in QTP? 

50. How will you handle custom object in QTP? 

51. Differences in QTP and Win Runner. 

52. Give us the Definition for Integration Testing, Regression Testing System Testing 

53. How will you report the bug and explain the defect tracking Sheet you handled? 

54. What In-string function will do? 

55. What is L-trim function will do? 

56. WinRunner and QTP difference? 

57. In website, protocol has been changed http: to https what you will do? Tell me your Approach? 

58. What Framework you are following? 

59. How to load the object repository at run time? 

60. How much strong on VB and C? 

61. How to compare the 2 strings? 

62. What is the Silent mode in WinRunner? 

63. Have you worked with Quality Center? 

64. Have you used Test Director? 

65. What is QTP Test Frame work? 

66. Definitions for Keyword view and Tree View? 

67. What is Smart Identification? 

68. What is Object Repository? 

69. What is your experience level in QTP? 

70. What is your Role and Responsibilities In QTP with your current organisation? 

71. Explain the following:

72. Import and Export of files. 

73. Random testing of 500 test cases. 

74. Invoking of application 

75. Opening notepad in QTP &Writing of Test Result in Notepad. 

76. Merging of Two Repositories 

77. Datafile / Verification of data file when file is not available in local system. 

78. Business process component / Types and usage. 

79. Opening of notepad in QTP to write and execute the coding. 

80. How to find local host name using QTP 

81. How to handle exception when data table is not available in local host system or Path is not          correct (Explain Statement with example) 

82. Runtime dynamic settings. 

83. Script generated after applying database check point. 

84. Script generated at the time of setting runtime property. 

85. Types of exception handling and script for that. 

86. Scripting

