Results 1 to 3 of 3

Thread: WATIR : no such file to load - appscript (LoadError)

  1. #1
    Contributing Member
    Join Date
    Feb 2010
    Answers
    49

    Question WATIR : no such file to load - appscript (LoadError)

    Dear Friends,

    In IE and FF browsers, my rb(Ruby) scripts have worked fine. But, when i tried to execute the same script in Safari it throws an error saying "c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_re
    quire': no such file to load -- appscript (LoadError)
    from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `re
    quire'"......

    Can anyone help me in this? Do i need to install anything else apart from Rubygems & Safari Watir?

    Thanks,
    Godwin


  2. #2
    Contributing Member
    Join Date
    Feb 2010
    Answers
    49

    Thumbs up Re: WATIR : no such file to load - appscript (LoadError)

    Dear Friends,

    To your information,
    Watir works in safari only on MAC and not on Windows XP(As of today).

    Regarding Chrome, don't install chromewatir driver instead try installing Web driver,which infact contains chromewatir driver in it. And it will work fine in chrome.
    zeljkofilipin . com/2010/01/12/watir-on-webdriver/


    Thanks,
    Godwin


  3. #3
    Contributing Member
    Join Date
    Feb 2010
    Answers
    49

    Re: WATIR : no such file to load - appscript (LoadError)

    Quote Originally Posted by GodwinQA View Post
    Dear Friends,

    In IE and FF browsers, my rb(Ruby) scripts have worked fine. But, when i tried to execute the same script in Safari it throws an error saying "c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_re
    quire': no such file to load -- appscript (LoadError)
    from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `re
    quire'"......

    Can anyone help me in this? Do i need to install anything else apart from Rubygems & Safari Watir?

    Thanks,
    Godwin

    Dear Friends,

    Its just an info,
    SafariWATIR - Doesn't work on Windows XP and it works only on MAC OS.
    ChromeWatir - This library has been no more in Rubygems and one should install Watir-Webdriver in order to work in Google Chrome.


    Thanks,
    Godwin


  4.  Sponsored Ads
    Ad


     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
Applying for a job can be a stressful and frustrating experience, especially for someone who has never done it before. Considering that you are competing for the position with a at least a dozen other applicants, it is imperative that you thoroughly prepare for the job interview, in order to stand a good chance of getting hired. That's where GeekInterview can help.
Interact